[BXXPwg] rename MSG to REQ

Wolfgang Hoschek wolfgang.hoschek@cern.ch
Mon, 11 Dec 2000 01:56:24 +0100


At the rist of sounding picky, in draft 08, I believe the teminology
surrounding "MSG" and "message" is unncessearily overloaded. 

A message is a very generic concept, and in the the BEEP context can be
of various kinds: MSG, RPY, ANS, ERR, NUL, SEQ. In oral conversation
about BEEP (and also to a lesser extend in code, mails, doc) it is hard
to differentiate between MSG and message. Hence people reside to
constructs such as "message of type MSG".

Person X to person Y: "I received a message and didn't know how to
process it"
Person X to person Y: "I received a MSG and didn't know how to process
it"
Person X to person Y: "I received a message of type MSG and didn't know
how to process it"
What does it mean? Just say it aloud to hear that there is no difference
(or it doesn't make sense).

As another example, trying to implement beep, one almost inevitably
comes across idioms like

handle(Message msg)
handle(Message message)
handle(MSG message)
or similar.

Renaming "MSG" to "REQ" (or similar) would do away with these
difficulties. It would encourage a well understood vocabulary,
disambiguate conversation and increase usability.

If this could be cleaned up as long as it is still possible, it would
help. IMHO, with BEEP implementations still in their early stages this
seems (still) easy to do, while it would be very hard at some late point
in time.

Regards,
Wolfgang.